FJ battery draining completely

Post Reply
User avatar
Vish
Major
Major
Posts: 92
Real Name: Doe
Vehicle Make & Model: FJ Extreme 2106
Pajero Adventure (3.8L, SWB) 2016
Disclaimer: Agreed and Signed.
Nickname: Vish
Number of drives: 52
Blood Group: A+

FJ battery draining completely

Post by Vish » Tue Mar 05, 2019 10:23 am

I faced complete draining of the battery if I don’t start the car for couple of weeks or more. Al Futtaim could not find anything wrong. I have kill switch, led by Titan. Changed battery once within a year and that also dead with couple of weeks non use. Other than battery change concern is any leaking current.
Any one faced such issues?
What battery would you recommend?
Any good shops in Al Quoz?
Would you recommend a battery switch?



User avatar
Pierre2016
Major
Major
Posts: 124
Real Name: Marfisi pierre
Vehicle Make & Model: Toyota FJ Cruiser
Disclaimer: Agreed and Signed.
Nickname: Pierre
Number of drives: 90
Blood Group: O+

Post by Pierre2016 » Tue Mar 05, 2019 11:01 am

No such battery issue with my FJ. For sure there is something wrong that Al Futtaim didn't found. Mat be you should have the car checked by a professional garage like Titan?



User avatar
Alex
Colonel
Colonel
Posts: 463
Real Name: Doe
Vehicle Make & Model: FJ dark-pink
Disclaimer: Agreed and Signed.
Nickname: Fon Genrih
Number of drives: 100
Blood Group: A

Post by Alex » Tue Mar 05, 2019 11:46 am

Vish wrote:
Tue Mar 05, 2019 10:23 am
I faced complete draining of the battery if I don’t start the car for couple of weeks or more. Al Futtaim could not find anything wrong. I have kill switch, led by Titan. Changed battery once within a year and that also dead with couple of weeks non use. Other than battery change concern is any leaking current.
Any one faced such issues?
What battery would you recommend?
Any good shops in Al Quoz?
Would you recommend a battery switch?
Unfortunately, cuz of heat batteries life here is too short, 2 years maximum as far as i know! i normally change every 2 years, when u buy new, make sure that it was made not too long time ago, better that made date less than a month. i got last from Ras Al Khor shops for 250 or even less Aed with a year warranty.
If i leave car for more than a week i normally unplag the +
Cuz i have some extra relle and OBD connected even when car is off, so, they might also cause A or V drainage



User avatar
Bernardo

Marshal
Colonel
Colonel
Posts: 197
Medals: 1
Real Name: Bernardo
Vehicle Make & Model: FJ Cruiser
Disclaimer: Agreed and Signed.
Nickname: Bernardo
Number of drives: 100
Location: Dubai
Blood Group: O+

Post by Bernardo » Tue Mar 05, 2019 2:40 pm

I had no issues with mine and I also have a kill switch led by Titan.
What Simon said makes sense to me. Al Futtain couldn’t find what’s wrong with it.



Asim

Post by Asim » Tue Mar 05, 2019 3:59 pm

Hi Vish,

You problem sounds like battery voltage/ amp leak and or parasitic battery leak.

This normally happens when a particular circuit draws power even when the car is off. Normally it is very hard to pin point the leak but i guess Shibu should be able to find the leak. In older and complicated vehicles they use a battery kill switch which disconnects the battery as a solution for the voltage leak.

Secondly, you may also want to get your alternator i.e. dynamo tested.

Btw, did u recently install any new electrical accessory? Lights, amplifier, winch etc etc.

Hope this helps, keep us posted



User avatar
Sahil Trehan
Major
Major
Posts: 249
Real Name: Sahil Trehan
Vehicle Make & Model: '16 Jeep Wrangler Sport
2 Door - Manual Transmission
Disclaimer: Agreed and Signed.
Number of drives: 50

Post by Sahil Trehan » Tue Mar 05, 2019 5:35 pm

Sounds like the alternator isn’t holding the voltage..


Sahil Trehan
0507005557

Plus Est En Vous :o)

User avatar
Vish
Major
Major
Posts: 92
Real Name: Doe
Vehicle Make & Model: FJ Extreme 2106
Pajero Adventure (3.8L, SWB) 2016
Disclaimer: Agreed and Signed.
Nickname: Vish
Number of drives: 52
Blood Group: A+

Post by Vish » Tue Mar 05, 2019 7:27 pm

Car is absolutely fine. No issue with charging as with new battery - changed today everything is fine. Issue is only when no use for 2 weeks or so. I guess could be what Asim mentioned - some parasitic leak however AL Futtaim said they didn't find anything wrong. I have kill switch, Pedalbox and LED lights. Anyway going to disconnect battery on long periods of non use as Alex does. Thanks for the views.



Post Reply